Eclipse error: Failed to load JavaHL library

In Eclipse IDE, we may meet error as “Failed to load JavaHL library.” This error message means Eclipse IDE cannot find the bottom layer of JavaHL library to support SVN functions inside the Eclipse environment.

To get rid of the error, we must install the required low layer JavaHL library. There are two methods we can do:

1. Native JavaHL library
According to various OS you are running, you can install different native library/plugin/tool.
Example, people usually install Silksvn as a native tool.

2. Use SVNKit Java library within Eclipse
On menu bar, click [Window] –> [Preferences]
Navigate to [Team] –> [SVN]
For SVN interface, select SVNKit as the client.

oliver

Leave a Reply

Your email address will not be published. Required fields are marked *


*